Ask a Question

[NewtonVR] Critical Error: Oculus / SteamVR not setup properly or no headset found.

So I changed nothing in the scene, hit play and now it isn't detecting my steamVR setup, after weeks of it working. Its done this twice now out of nowhere, the vive is still working because I am now just stuck in steamVR home. Any fix? I've restarted computer, added it to a new project and restarted unity scene several times. In steamVR it is picking up the HMD and controllers perfectly fine.

Oculus touch controller models not tracking

Hello. First off want to say I love your plugin. I've been using it for a while with the vive and it really helps. For the project I'm working on we want to set it up with the Oculus now as well to compare it with the vive. I was using an older version of Newton VR to begin with so the current version is new to me and I'm still learning about all the changes. My question is about the option for using the oculus touch controllers. I have the NVR player checked to use oculus sdk and the headset works and I can see the scene. However the controller models are not tracking with the controllers. The controllers are being tracked by Steam VR though, as in if I have the demo scene off and look in the headset I can see the Steam VR home room and the controllers are tracking like normal, and while the demo scene is running if I put the controller up to the edge I can see the Guardian appear showing that the controller is exiting the play area. I can see the models on the floor in the middle of the scene and sometimes the buttons move when pressed but they are not tracking so I cant interact with anything. I wasnt sure if I was missing a setting or something. There are no errors in the console log. Any ideas what might be the problem? Im using these plugins: Newton VR v 1.193 Steam VR v 1.2.1 Oculus Utilities SDK v 1.10.0 Thanks again for all your hard work.

2 controller grabbing of an object?

How would I apply NewtonVR to be able to grab an object with both controllers? VRTK has the ability, but I need NewtonVR's ability to use the rigidbody on the object to interact with the environment and not pass through colliders. It works great 1 handed but I can't figure out how to do 2 handed. Thanks so much! I've spent hours and hours looking at the code, messing with the code, and I just can't seem to figure it out.

Headset stuck on loading screen

Hi, I'm trying to use NewtonVr with oculus rift for a game I'm working on but I keep running into an issue. The SDK works fine when dropped into a new project (I think I could use pointers on how specifically to bring it into the project. More on that later) but we are using unity collab to have multiple people working on the project, and whenever I upload a project with NewtonVr in it to collab and pull it onto another machine it stops working. Details on Issue: When I enter play mode in the editor it enters play mode fine, however the rift headset goes into the white grid scene, shows a loading screen and stays there indefinitely. In the editor I can see the cameras on the NVR player moving, and the headset is being tracked, but I am not able to see the game in the headset. There are no errors or warnings in the console, but after the first time the loading screen comes up, the headset usually stays stuck on the loading screen and won't go back to oculus home. Sometimes it will go back to oculus home but it's inconsistent. We were also attempting to use VRTK, and after watching a tutorial on the VRTK youtube we were trying to use NVR for the camera rig, and VRTK for movement and teleportation. This didn't seem to be working well so we abandoned this idea and we are trying to just use NVR. I bring it up because VRTK is still in the project and there are scripting define symbols associated with VRTK still in the player settings. Has anyone else experienced this issue? Are there any settings I can check that might help me narrow down what's happening? Without any errors in the console I'm not sure where to start looking to fix the problem. We are using Unity version 2018.3.12f1, Oculus Utilites v1.36.0, and OVRPlugin v1.36.0 On the topic of bringing NVR into the project: The documentation details out the process of adding links via the command prompt and I'm not sure if I understand what that process is doing. In my project I had just unzipped the NVR repo download and dragged it into the project hierarchy, I don't know if this is correct, but it was working fine when I did it in new test projects.) I would really appreciate any help anyone can offer.

Held Objects Jitter Wildly

I've found that when I import this asset from the asset store into my existing projects (I've tried 2 separate ones) when I pick up any object (including the the example scene) the objects just jitter around like crazy when held. At first I thought it was a physics layer thing but I couldn't figure out anything while testing. If I pull the project from GitHub everything works just fine. I'm sure it's something silly but I was wondering if anyone knew what this was being caused by? Thanks

Overriding models breaks ability to interact with objects

When I override the hand models either for either SteamVR or for all SDKs I lose the ability to interact with objects. If I stop playback and switch off the Override models checkbox in NVRPlayer and play the application it all works again using the standard models. So to be clear, I override with controller models for each hands and mesh colliders as well (the colliders are present on the prefab GO I put in all 4 references in NVRPlayer). The colliders work, I cant push my hand through walls and I can collide with the buttons - but I cant interact with the drawer or anything using grip.

Does not work with Unity 5.6b

I get error message: "GL.End requires material.SetPass before!" The latest SteamVR includes the following suggested fix: https://forum.unity3d.com/threads/steamvr-5-61-gl-end-requires-material-setpass-before.446167/ But, NewtonVR camera rig prefab still has the error.

Moving forward with joystick following head direction

Hi, I'm pretty newbie with Unity so please don't punch too hard :) I'm trying to get the Oculus' joystick to move forward my NVRPlayer, following the head direction (so not just going forward "absolute direction", but forward "towards what I am looking at"). I tried to parent the NVRPlayer to the OVRController but for some reason the head movements are not 100% correct and it causes nausea. Any idea? thanks in advance, I owe you a beer! ;)

Doesn't Work With Teleporting

Hey, I'm loving the asset so far! However I'm having one major issue and that's the fact that I can't teleport the player anywhere without them losing grip of their held object. I'm using 'VR Arc Teleporter' from the asset store. I would love to see this either fixed or hear a solution or else this won't work with any game that uses teleportation. Thanks!

SteamVR_Controller Broken.

The NVRSteamVRInputDevice Script is throwing an error "Assets/NewtonVR/SteamVR/NVRSteamVRInputDevice.cs(16,17): error CS0246: The type or namespace name `SteamVR_Controller' could not be found. Are you missing an assembly reference?" Iv'e tried fixing myself but just cant figure it out. Please help me fix this or release a patch to fix it.